
What You Should Know Before Starting Work 

 

DIGIWIEGH Label Editor is a program for designing and printing labels, developed to 

work with label printers DIGIWEIGH DW-PRT24T. It shows you onscreen just how the 

label will look when printed, and allows you to make the necessary corrections before 

printing or loading the label design in the printer. The exact correspondence guarantees 

that every dot you can see on the screen will be printed at precisely the same area of the 

label, as long as the label has the required size. 

 

In order to use all the options of the printer, the program’s organization was developed so 

as to follow the printer’s mode of operation. That is why the image editor looks 

somewhat different from Paint or Photoshop for example.  

 

Each label is made up of several, different graphic elements, known as objects. Each 

object is independent and can be moved, edited or deleted on its own.  Objects can be 

created from the Draw menu item. Right-click on an object to bring up a properties dialog 

box where you can change the location and appearance of the selected object. Left-click 

to select, move or resize an object, if possible. The way you can move and resize an 

object is not the same for all elements and is explained in the objects’ description. 

Deleting an object is done by selecting an object and pressing the <Del> key on your 

keyboard. Selection of multiple objects can be done by clicking on each of them with the 

<Shift > key held down, or by group selection where you must zone at least one of the 

corners of the selected object. Moving several objects is done by selecting them and 

moving one of them – they will all move together. 

 

 

Basic Concepts Used 

 

· Form 

 

A form is a label design loaded in the printer. It is a text file containing commands for the 

printer. The name of the form in the printer is limited to 8 symbols, only Latin letters and 

digits are allowed. CAPS make no difference – “Label1” and “ 

LABEL1” will be recognized as one and the same form. The form DOES NOT contain 

the graphics and loadable fonts it uses. Therefore, if you manually delete a graphic from 

the printer, the form that uses it will not be able to find it and the respective area on the 

printed label will be empty (but no error or program /printer block will occur). 

 

If you save the label design with “Save as Form” you will save on the disk exactly this 

text file, which may not be enough for reproducing the label, since it does not carry the 

graphics and fonts. This save option is left for compatibility with older label printer 

versions, which support only this format. That is why, if this is not the case, save your 

label designs with the “Save as Label” option. 

 



There could be many forms with different names in the printer. However, only one of 

them could be active at a particular moment, and only this active form will be issued at a 

print command. 

 

· Variables and Counters 

 

The variables and counter are simply a location in the program or the printer allocated for 

a text, which can be entered later, just before a print run. The counters also have the 

quality to increase with a fixed step (increment) after a print command. You can use 

variables and counters for those parts of a label, which will change often (e.g.: items’ 

names, prices, weight). This mode of work is obligatory, if you design a label for use 

with a digital scale, because variables are the only way for the scales to send the weight 

data to the printer. Variables are set in advance from Print->Define Variables or the 

corresponding button, and their value can be changed later, usually before print from 

Print->Update Variables, or by means of the button in the print dialog box itself. 

 

The variables and counters have the following properties: 

 

· Maximum length 

· Prompt – a reminder text, useful for reference when working with variables and 

counters later. 

· Alignment – if their length is under the maximum, and in that case also- fill 

characters. 

· Increment step – only for counters. 

 

· Label 

 

A label (label design) is the inner format of DIGIWEIGH Label Editor. It contains the 

commands for the printer and all the additional information needed for printing the label 

(graphics and fonts). This is not a text file and you cannot open it with a text editor, 

unlike the form. Saving a label on the disk records all the information, including the 

current contents of the variables and counters. When you open it later, you can proceed 

with your design whence you left it. 

 

When you save a label in the printer, the program automatically generates commands for 

the respective form and sends them to the printer, and also saves all the graphics and 

fonts the labels design uses. 

 

 

· Graphics 

 

A graphic is an object in the printer, which saves information about the graphic image 

(picture). A graphic has a name by which any form can send for it. The requirements for 

the graphic’s name are the same as those for the form. 

 

· Font 



 

A font is an object in the printer that saves information about a loadable font. The name 

of the font is of one Latin letter, CAPS make no difference. The font is identified by this 

name when send for from a print text command. If there is no font with such a name, the 

print text command will not be executed. The loadable fonts may contain from 1 to 224 

characters, which may be not successive. 

 

· Printer’s memory 

 

The forms, graphics and loadable fonts share the memory of the printer. They are 

recorded there as are the files on the disk: they have names – you can delete and export 

them from the printer, as well as receive the list of the already loaded objects. The sum of 

forms, graphics mad fonts must not exceed 500 KB, though this limit will be higher with 

future versions of the printer. The number of objects that the printer can record is 512. If 

you reach the number limit or have a full memory, you must delete some of the objects in 

order to proceed, or work in Test print mode. 

 

· Print and Test Print 

 

The standard method of working with the printer is to load a label design in the device, 

make it active and pint the label (possibly with new values set for the variables). All the 

information needed is already in the printer, except the variables, and what follows is a 

print command. This is the only way of operating with digital scales. 

 

0 Another method Is possible: If currently there is no active form, the printer will 

automatically carry out any commands, and in case of a print command it will print on 

the label the result of the received commands. This is used in test printing, which is a 

print-out of the onscreen label, without loading it in the printer. This may be useful in 

several cases: 

 

· To print out a paper - preview of the current label design before loading it in the 

printer. 

· The label design contains a small piece of information that you will not need later.  

· There is no free memory in the printer and you cannot or want not to choose what 

to delete. 

· You work with a large number of different labels, which you change often. It is 

more convenient to keep them on the disk and load them only in case you need them – 

the memory limit will not be a problem. 

 

The main difference between the two methods is that during the test printing what is 

transferred through the serial port is all the data contained in the label design; while 

during the standard method what is transferred is the new values of the variables. If the 

label design has a large picture (graphic), or uses loadable fonts and you work at a lower 

communication speed, the transfer may take quite a while. A combined approach is 

possible – if we know that the graphic we are using is loaded in the printer, we can order 

the program to get the data directly from there, without sending it every time afresh. To 



do this, go to Tools->Settings, or click the Settings button. The “Test print” field offers 

two choices: 

 

· “ Send fonts and graphics directly” – the program sends all the necessary 

information to the printer repeatedly. The print will be correct, but eventually slower. 

· “ Use stored fonts and graphics” – the printer will search for the graphics and 

fonts in its memory. The sending of data will be fast, but if the graphics and fonts are not 

in the memory, their respective place on the label will be empty. 

 

 

 

What You Should Be Careful About 

 

· When you enter text and barcode data bear in mind that you must follow the rules 

stated in Text and barcode information format. If there is a mistake, the text will be 

substituted with “@@@@”, and the barcode will appear on the screen with a red 

strikethrough. This means that the printer will not receive the data and the object will not 

be printed. You must find and correct the mistake. Note that most of the barcodes have 

requirements – number of symbols allowed and information length. If they are not met, 

the barcode on the screen will be crossed out and will not be printed. 

 

· When you print a batch of labels, the printing head may get overheated and the 

printer will stop to cool out. It is advisable you don’t print more than some hundreds of 

labels with one print command. 

 

· The program does not keep track of changes in the label design. So before 

opening a new label, loading a label from the disk, or exiting the program, be sure to save 

the label design on the disk, or the printer. Otherwise it will be lost.  

 

· The printer’s memory is power-independent (flash) and keeps all the saved data 

after the device is switched off, unless you delete it or format the memory. Even though 

the memory could be overwritten ten thousands times, but still a limited number of times, 

it is not advisable that you perform actions that write or delete information in the memory 

needlessly. When you design a new label, use the test print to make sure everything is 

OK, and load the label in the printer only when the label design is ready. You can make 

temporary saves on the disk of course. 

 

· When you load a label design in the printer, the device also automatically saves 

all the graphics and fonts, that were used, with names as those you set in the program. If 

the memory of the printer contains graphics or fonts with such names, the new 

information will overwrite them without warning. This could be a problem when some 

other form uses a graphic/font with this name. Make sure the names of the graphics and 

fonts do not match. 

 

 

 



Object Types 

 

· Text 

 

The text object displays information with a set font and orientation. There are 5 in-built 

fonts supported, with sizes: 8x12, 10x16, 12x20, 14x24 and 32x48 pxls. Font 5 (32x48) 

contains only CAPS. You can use external fonts, which you must load in the program 

beforehand from Tools->Add New Font. The text properties allow you to select: the 

coordinates of the top left corner of the text object; font; font style (normal, bold, italic, 

inverse); horizontal or vertical size-increase; rotation (0, 90, 180, 270 degrees); 

information to be printed. The loadable fonts have only the normal print mode property. 

See Text information format. To move a text object left - click on the text and drag with 

the mouse key held down. Text objects cannot be resized – the size depends on the font 

and the font size.  

 

· Barcode 

 

The barcode object is a type of barcode. The program supports the most widely used 

barcodes. The barcode properties allow you to select: coordinates of the barcode top left 

corner; barcode type, narrow and wide bar thickness; height, rotation (0, 90, 180, and 270 

degrees), show and justify barcode text. Some types of barcodes do not support wide bar 

thickness. The Text information format is identical to that for the Text object. To move 

the barcode object, left-click on it and drag with the key held down. Changing the size is 

possible only by changing the height and clicking with the left mouse button on the lower 

part of the barcode – the object will appear surrounded by a frame. 

 

· Rectangle 

 

Draws a rectangle area on the label design, which can be black, white or inverse. The 

white and inverse option allow you to change the appearance of objects that were drawn 

earlier and will be covered by the rectangle. For example, you can write some text and 

make the letter white on a black background, by placing a rectangle over the text, with a 

suitable size and inverse colour. The white colour deletes everything that comes under the 

rectangle – you can delete unwanted parts of other objects in that way. The rectangle 

properties allow you to select: the coordinates of the top left corner of the rectangle; 

rectangle’s width, height, and colour. To move the rectangle, left-click on the object and 

drag the mouse with the mouse held down. To change the size, left click the object near 

the corners – the frame will appear as a thick red frame. 

 

· Diagonal Line 

 

Draws a line with a set thickness, which can be black, white or inverse. The use of the 

white and inverse color option is the same as with the rectangle. You have the choice to 

select: the coordinates of the two end points, thickness and color. Moving is done by left-

clicking the line and dragging it with the mouse to a new location on the label design 



area. To change size and slant, left click the object at the end – a thickened red frame will 

appear. 

 

· Box 

 

Draws a rectangle box with a set thickness and black colour. You can set the coordinates 

of the top left corner and box line thickness. Line thickening is done at the expense of the 

internal space. To move the box object, select the item by clicking on some of the lines, 

hold down the left mouse button and drag the object. Resize by selecting the object so as 

the frame to appear indicating the stretch directions. 

 

· Picture 

 

Displays a black-and-white image on a selected area on the label design. The program 

takes the picture data from a file, which must be monochrome, BMP/PCX format. What 

is loaded is the whole image – you cannot select parts of it. You can define the 

coordinates of the top left corner, the file path and name. The picture will be loaded in the 

printer as a graphic with the same name. This is useful when you want this picture to be 

used by different label designs, no matter that the graphic was loaded only once (for 

example – you can load a graphic with your company logo). Move a picture by left-

clicking on it and dragging it to another area. Pictures cannot be resized. If you want to 

use a colour image of BMP/JPG format, you must first convert the image from Tools-

>Color To Black & White Converter and save the file on the disk. 

 

· 2-D barcode PDF417 

 

Draws a barcode PDF417. The barcode properties allow you to select the position, 

rotation (0, 90, 180, and 270 degrees), maximum width and height, maximum bar width 

and height, maximum row and column count, the compression method and the barcode 

data. The Text information format is described in a separate topic. To move the barcode 

object, left-click on it and drag with the key held down. To change the size select the 

right lower corner of the barcode (it’s position depends on the rotation) - the object will 

appear surrounded by a frame. 

 

 

 

Text and Barcode Information Format 

 

The text and barcode information could be comprised of several fields that contain free 

text, the current date and time and some of the set and initiated variables and counters. 

The elements are arranged from left to right according to their description and form the 

text that will be printed or encoded in the barcode. The fields are: 

 

· Free text 

 



The free text is entered directly, only it must be enclosed by quotation marks. If the text 

itself must contain a quotation mark, its quotation mark must be preceded by a ‘\’. For 2D 

barcode PDF417 only – control symbols (ASCII codes bellow 32) can be encoded using 

the syntax ‘\dd’, where dd is the decimal representation of the ASCII code. 

 

· Current Date 

 

The code is TD[m]. m is an optional integer from –3500 to 3500, and sets a difference 

from the current date in days – you can use this to set an expiry date. Date could be 

formatted in several ways from File->Label Setup or by pressing the corresponding 

button. 

 

· Current Time 

 

The time code is TT. Time format can be set from File->Label Setup. 

 

· Variable 

 

Format – Vn[Modifiers]. 

 

n is the number of the variable and can have a value from 0 to 31. 

 

The modifiers are indicators for separating symbols from the variable. Their number is 

arbitrary. If there are no modifiers, the variable is added as it is by default and 

initialization, without additional processing. In most cases, modifiers are not necessary. 

The printer works with the following modifiers: 

 

> Cuts off the leading symbols of the string that are identical with the symbol that 

follows the modifier’s sign. It can be used to remove leading zeroes or spaces. 

< Cuts off the end symbols of the string that are identical with the symbol that 

follows the modifier’s sign. 

Rn Leaves the right n symbols in the string. 

Ln Leaves the last n symbols in the string. 

Mm.n Gets n symbols from the string, starting at m position. 

 

# Removes the leading zeroes, if the string could be interpreted as an integer. 

Xmn Substitutes all symbols with value m with the n symbol. 

G After this symbol other modifiers must follow. They will act as global modifiers – 

the whole text until the current position will be changed, not the last variable or counter. 

 

· Counter 

 

Format Cn [Modifiers] 

 

n is the number of the counter and can have a value from 0 to 7. 

 



The modifiers are as those for the variables. 

 

The program and printer process the text and barcode data in the following order: 

 

· They get the subsequent element. 

· If the element is a variable or a counter, they get the current value. The text is 

formatted depending on its definition. All the modifiers are executed from left to right.  

· If the element is date or time, it is formatted as was set in Label Setup. 

· The resulting text is then added at the end of the text that was a result from the 

preceding elements.  

· The procedure continues till data finishes. 

 

Examples: 

 

“Date:”TD” Time: “TT 

 

will generate Date: 12.JAN.2003  Time: 16:30 

 

“Expiry Date: “TD+90 

 

will generate the text Expiry Date: 16.04.2003  

 

if the current date is 16.01.2003. 

 

“Price:”V2 

 

will generate Price: 1.20 

 

if the value of the variable V2 is “1.20” at the moment. 

 

V0> < C1L3 

 

will generate a string with a variable V0 with leading and end spaces removed and a 

counter C1 with the three left symbols removed. 

 

V0L1V0M3.2V0R1 

 

will generate a string that includes the first, third, forth and last symbol of the variable 

V0. 

 

Creating a New Label Design – Basic Steps 

 

· Determine the size of the paper label - so that you will know the dimensions of 

the working area. 

 



· Clear the screen of the Label Editor from any previous label designs with File-

>New Label. 

 

· Set a label size for the label design from Label Setup. If the label will contain date 

and time, set the date and time format. 

 

· Decide which part of the label information is to change often – it is a good idea to 

provide a variable for it. For example: - item’s name, weight, price. Set the necessary 

variables from Define variables and counters. When defining variables, try to estimate 

what length and justification would be best for the label outlook. Do not worry if you 

cannot decide immediately – these settings can be changed later. Set suitable and sensible 

names for the variables – this will greatly facilitate your work.   

 

· Start adding the necessary elements on the label, one at a time: press the draw 

button for the object and click on the label area where you want the object to appear. Of 

the object is a rectangle, frame or diagonal line, you can roughly set the initial size – hold 

down the left-mouse button and drag to resize. The object’s current position and size will 

be indicated by a thick red line or frame. 

 

· When you let go the mouse button, the object’s dialog box will appear where you 

can edit its parameters. When drawing text and barcodes, make sure you enter some data, 

otherwise the objects will not be visible. You can edit the entered information later. 

Choose font and enlargement, if necessary. 

 

· Arrange the objects on the label, so as to cover the area regularly. Do not forger to 

leave some empty space around barcode objects to ensure proper reading.  

 

· Set the values for the variables used with Update variables and counters. In case 

you have done that earlier, go around the text and barcode objects and check whether the 

entered date is valid and the correct variables are stated. The label design should be 

already finished – make a test print to preview it on the paper.  

 

· Save the new label on the disk with File->Save as Label. You can then save the 

label design in the printer with File->Store Current Label. The new label will be 

accessible for print with the Print button. 

 

Description of the menu items 

 

· File 

 

Load and save files, get data from the printer, store data in the printer and label setup. 

 

· Edit 

 

Edit commands. 

 



· View 

 

Settings for the DIGIWEIGH Label Editor’s screen. 

 

· Print 

Print and test print; variables and counters. 

 

· Draw 

Insert a new object on the label design. 

 

 

· Tools 

 

Additional procedures – fonts, color image conversion, terminal. 

 

 

· Help 

 

 

 

Toolbar Buttons 

 

Draw Text 

 

Opens a dialog for adding a text object. 

Also available from the Draw menu item. 

 

 

Draw Barcode 

 

Opens a dialog for adding a barcode object. 

Also available from the Draw menu item. 

 

 

Draw Rectangle 

 

Opens a dialog for adding a rectangle object. 

Also available from the Draw menu item. 

 

 

Diagonal Line 

 

Opens a dialog for adding a diagonal line object. 

Also available from the Draw menu item. 

 

 



Draw Box 

 

Opens a dialog for adding a box object. 

Also available from the Draw menu item. 

 

 

Draw Picture 

 

Opens a dialog for adding a picture object. 

Also available from the Draw menu item. 

 

 

Grid Size and Adjustment 

 

Opens a dialog box for adjustment. 

Also available from the Edit menu item. 

 

 

Files and Forms 

 

Opens a dialog window where you can handle the files on the disk and forms, graphics 

and fonts in the printer.  

Also available from the File menu item. 

 

 

Label Setup 

 

Opens a dialog window where you can set the basic label parameters and print: size, 

offset, print darkness and speed, date and time format, etc.  

Also available from the File menu item. 

 

 

Test Print 

 

Opens a dialog for test print, 

Also available from the Print menu item. 

 

 

Print 

 

Opens a dialog for print, 

Also available from the Print menu item. 

 

 

Define Variables and Counters 

 



Opens a window where you can set variables and counters. 

Also available from the Print menu item. 

 

 

Update Variables and Counters 

 

Opens a window where you can set new values for variables and counters. 

Also available from the Print menu item. 

 

 

Settings and Diagnostic 

 

Opens a dialog window, where you can set the serial port and the clock, and print a 

diagnostic information from the printer. 

Also available from the Tools menu item. 

 

 

 

Shortcut Key Combinations 

 

Ctrl-A Selects all the objects on the label design. 

Ctrl-B Places the selected object at first position in the object list. 

Ctrl-C Highlights the selected objects and marks them for copying. Except this the whole 

label is stored in the clipboard. 

Ctrl-J Opens the dialog for adjustment. 

Ctrl-M Opens a list of all objects on the label. 

Ctrl-R Rotates the label 90 degrees clockwise. 

Ctrl-T Places the selected object at end position in the object list.. 

 

Ctrl-U Unselects all selected objects. 

Ctrl-V Pastes a copy of all objects highlighted with Ctrl-C. 

Del Deletes all selected objects, after confirmation. 

F1 Opens the Help application. 

F2 Opens the test print dialog. 

F3 Opens the print dialog. 

F4 Allows you to set new values for variables and counters. 

 

 

 

 

 

 

Dialog boxes for creating and editing objects 

 

· Draw Text 

 



Create or edit a text object 

 

· Draw Barcode 

 

Create or edit a barcode object 

 

· Draw Rectangle 

 

Create or edit a rectangle object 

 

· Draw Diagonal Line 

 

Create or edit a diagonal line object 

 

· Draw Box 

 

Create or edit a box object 

 

· Draw Picture 

 

Insert or edit a graphic object 

 

· Draw Barcode PDF417 

 

Create or edit a 2-D barcode PDF417 

 

 

 

Dialog boxes for program setup and printer settings 

 

· Label Setup 

 

Label setup and some print parameters. 

 

· Settings and Diagnostic 

 

Options for setting the serial port and clock, and print of diagnostic information. 

 

· Align to Grid 

 

Set grid step (the regular space between the points of the pattern) and adjust size (objects 

will move in measured steps on the grid). 

 

· Objects List 

 

Opens a list of all the objects on the label where you can edit, rearrange or delete them. 



 

 

 

Color to Black & White Converter 

 

From this dialog you can convert color images of BMP or JPG format into a black-and-

white images to be used on the labels. You can clip off unwanted parts of the image, 

resize it, as well as make brightness and contrast adjustments. The top are of the window 

is the toolbar, and below is an area where the target and converted image are tiled 

vertically. Smaller graphics are automatically converted, whereas to convert a larger 

graphic, after adjusting the settings, you have to click the Convert button. 

 

If you need only a part of the converted image, you can frame it by holding down the left-

mouse button. The framed area can then be clipped of with Cut.  

 

 

· Load 

Selects a graphic file for conversion. 

 

 

· Convert 

Starts conversion. Smaller graphics are automatically converted. 

 

 

· Save 

Saves the converted black-and-white graphic on the disk. 

 

 

· Reset 

Cancels the color corrections and resize changes of the black-and white image. 

 

 

· Test 

Sends the black-and-white image from the right pane of the screen to the printer to be 

tested. 

 

 

· Cut 

Clips off a framed are from the image in the left pane. The cut part becomes the new 

target image.  

 

 

· Width 

Changes the width of the graphic. If Constrain Proportions is checked, Height is also 

automatically updated. 

 



 

· Height 

Changes the height of the graphic. If Constrain Proportions is checked, Width is also 

automatically updated. 

 

 

· Rotation 

Rotates the graphic at 90, 180 and 270 degrees. 

 

· Constrain Proportions 

Determines whether the width/height ratio must be preserved. If checked, changes in the 

width will automatically update the height value, and vice-versa. 

 

· 50% Threshold 

Check to use a simple conversion procedure. This is a simple check per dot for 50 % 

brightness – if higher, the dot becomes white, if lower – black. In some cases this 

procedure is a more suitable conversion method. 

 

· Brightness 

Changes the brightness of the black-and-white image. 

 

 

· Contrast 

Changes the contrast of the black-and-white image. 

 

 

· Color Settings 

The Red, Green and Blue color channels allow you to modify the color image in a way 

that will affect the black-and-white image. 

 

True Type to Label Printer Font Converter 

 

From this window you can create a matrix font for the label, on the base of some of the 

installed TrueType fonts. 

 

The loadable fonts for the DW-PRT24T printers can consist of an arbitrary number of 

symbols that may not be successive. Since the printer’s memory is limited, it is preferable 

if the font contains only the symbols you will need. Working with loadable fonts is the 

same as with the in-built fonts – they can be rotated and multiplied by an integer along 

the X and Y coordinate independently. The only difference is that they cannot be printed 

in Bold or Inverse style. They are also proportional – i.e. each symbol has a different 

width (for example ‘w’ is wider that ‘i’) and it is difficult to assume what the width of the 

whole text will be. 

 

· Font 

Use the drop-down menu to select a font to use. 



 

 

· Style 

Sets an attribute – Regular, Bold, Italic, Bold Italic. 

 

 

· Script 

Select the character set for a country. 

 

 

· Top Pane 

This is the pane where you can select the symbols to be copied. Select a symbol, then in 

the bottom pane position the mouse pointer at a cell where you want that symbol to be 

placed and click Copy. To copy a symbol at exactly the same place in the bottom table, 

double-click on it. 

 

 

· Bottom Pane 

This is the pane where you copy the symbols. The symbols listed in this pane will be 

included in the font. 

 

 

· Clear 

Clears all the symbols listed in the bottom pane. 

 

 

· Clear Marked 

Clears a selected/highlighted symbol from the bottom pane. 

 

 

· Copy 

Copies the selected symbol from the top pane in the bottom pane – the start position is 

the position of the mouse pointer. 

 

 

· Undo 

Cancels a copy or delete operation. 

 

 

· Preview 

Opens a dialog box, where you can access some additional font setting. The options are: 

 

 

· Width correction 

Narrow or widen the symbols in horizontal direction up to 2 times. 

 



 

· Size 

Select the font height. 

 

 

· Space 

Sets a symbols interval. The label printers automatically add a white frame of 1 pixel 

around a symbol and the printed text appears wider. To avoid this, for Space. select a 

value –2. Allowed values are –16~16. Large negative values will result in overlapping 

symbols. The Space value makes no difference to the size of the generated file. 

 

 

· Remove Blank Lines 

If you have not selected the whole font, probably it is possible to remove some top and 

bottom lines without covering the symbols. This will decrease the amount of memory the 

font will occupy. You can either set values for Top and Bottom or check Auto. The blank 

lines will be colored in blue for easy observation. 

 

 

· Save 

Enter a file name as save the file. To load the new font in the label go to Tools->Add 

New Font . 

 

 

 

Character Set Viewer 

 

You can see here the languages and the ASCII codes of the symbols for each of them, 

supported by the Label Editor and the printers. 

Drop list “Language” selects the character table and “Font” selects the font. If the current 

label contains loadable fonts, they are in the list, too. When the mouse cursor moves over 

a symbol, the ASCII code of the symbol is displayed on the right upper part of the 

window in decimal and hexadecimal mode. 

 

You can copy the character table using Ctrl-C to the Clipboard as graphics for use in 

other programs. The same thing can be done clicking the right mouse button – a popup 

menu appears. 

 

 

 

 

Frequently Asked Questions 

 

Question: There is no connection with the printer. What may be the problem? 

Answer: Possible Reasons: 

 



· Check if the printer is switched on and properly connected to the computer. 

· Check whether you have selected the correct serial port. 

· Check if the selected baud rate and protocol for the serial port match the position 

of the switches in the printer.  

· Make sure the operation mode set by the switches is NOT DW-PRT24T 

Compatibility– the printer does not work with the program, when in this mode. 

· Check if there is another application that uses the serial port. 

 

· If when switching on the printer you have printed a diagnostic info with the LF 

button, switch off /on the printer. 

· Switch off /on the printer and try again. The printer may be trying to receive some 

kind of data. 

 

Question:  How can I check what is the baud rate of the serial port? 

Answer:  When you switch on the printer, press down the LF button. The printer 

will issue a diagnostic information – printer’s version, language, baud rate, switches’ 

positions, printing head temperature, free memory space and current settings. Then you 

MUST turn off/on the printer, because it is in Dump mode and does not run commands. 

 

Question:  What kind of labels and paper-rolls can I use with DW-PRT24T  

Answer:  DW-PRT24T label and paper roll width: 56 mm. Use the switch to select 

paper/label mode. The length of the labels can be different, the maximum value is 170 

mm. The label roll MUST NOT be with a black line. 

 

Question: Can I use DIGIWEIGH Label Editor with other printers, except DW-PRT24T? 

Answer:  No, or at least to an limited extent. You can load a form that will be compatible 

with the most commonly used label printers (those of them that use EPL2 as a program 

language) if you: do not use modifiers in text and barcode data; do not use barcode text 

justification; do not use white and inverse color for diagonal lines. You can even create a 

font for such type of printer. But a reliable communication and print from the program 

are possible only using the DIGIWEIGH printers. 

 

Question: The graphic I use in the label is displayed onscreen, but does not print out. 

Why? 

Answer: If you use the test print command, go to Settings and Diagnostic and check 

the status Test print. If the field selection is Use stored graphics and fonts and the graphic 

is not loaded in the printer, it will not be printed out. The same problem may occur with 

loadable fonts. 

 

Question: The printer often fails to print some objects from the label, and the 

program displays communication error? 

Answer: The serial port is probably loaded almost to its limits. If the connecting 

cable of the printer is longer that 2 meters, and especially if you are using two connected 

cables, you may be experiencing some problem with the 115200 baud rate and must 

change the speed. 

 



If this is not the case, check if the program uses a hardware protocol, and the printer – a 

Xon/Xoff one. With a larger data transfer this could be a reason for the problem. 

 

There may be some hardware problem with the computer or printer’s serial port. 

 

Question: The print is too thin. Why? 

Answer: Maybe you set low darkness print from . The label paper may be of poor 

quality, or too old – this makes the paper less sensitive. 

 

Keep in mind that thermal print manages poorly the thin lines (of 1 pixel width), 

especially horizontal lines so avoid using them. 

 

 

Question: The printer cannot recognize the beginning of the label properly. Why? 

Answer: You have probably set a continuous paper working mode, or the type of 

labels you are using is not suitable. DW-PRT24T labels must not have a black line 

If the printer recognizes every label but repeatedly fails to start at the beginning, go to 

Label Setup and check the values of Offset, Left margin è Top margin for any 

displacement. 

 

Question: Why does the printer indicate “out of paper, when there is paper loaded? 

Answer: See the answer above. 

 

Question: Why does not the printer print on the whole label area? 

Answer: With DW-PRT24T the width of the printing area is 48 mm, which is less 

than the label width. You cannot change this, since it depends on the printing head width. 

 

Question: How can I create a form containing variables and counters, that I want to 

use with another program or printing device? 

Answer: When you want to print a label from another program and device, all the 

data that you want to change, must be placed in variables or counters. The elements of the 

label can be arranged as you like. Make sure you provided enough space for the texts and 

barcodes, when their data is of maximum length. Load the label in the printer. 

 

What the different application or device has to do is to activate the form, send the new 

values of the variables and counter and give a print order. This is done by sending direct 

commands to the printer through the serial port. 

 

Send <LF> (ASCII code 10) – this will clear the printer’s buffer. 

 

Send FR”FormName”<LF> command, where FormName is the name of the form in the 

printer. The quotation marks are obligatory, space between symbols is not allowed, the 

line finishes with <LF>. This command will set the form active. 

 

Send ?<LF> command. This tells the printer to wait for new values of the variables and 

counters. 



 

For each of the variables and counters, defined in the form, send a single-line text ending 

in <LF> (ASCII code 10). The variables are sent first, then the counters, by ascending 

number. If you want to preserve the old value of a variable, send a blank line (only 

<LF>). 

 

Send print command Pn,m<LF>. m is the number of identical labels to be printed. n 

defines how many sets of m labels will be printed. This can be used when we work with 

counters – after printing a set of labels their value will change automatically. To print one 

label, the value of n and m must be 1.  

 

For more information read the An example of creating a label for digital scales and the 

manual for the printer. 

 

Question: What is the largest size of a graphic the printer can load? 

Answer:  The file size depends on the free memory space, but it cannot exceed 48 

KB. The printers support only PCX monochrome format, but the program can load also 

monochrome BMP graphics by converting them before sending them to the printer. Since 

the PCX files are compressed, you may assume that the size, after conversion will 

decrease (graphics that are a result from a photo, make an exception – usually they cannot 

be compressed). If the graphic has X and Y values larger that the label’s, clip off the 

unwanted parts or resize it beforehand not to occupy memory space unnecessarily. 

Colour graphics can be converted to black-and-white images from Tools->Color to Black 

& White Converter èëè or other application. 

 

Question: The barcode element on the label is not printed out 

Answer: You may have entered unalloyed barcode data. Usually this happens when 

the barcode uses a variable – the change in the variable made the barcode invalid. Invalid 

barcode will be displayed on the screen as crossed with a red line. Check the barcode 

data. You can reference EAN 13, EAN 8, UPC-A, UPC-E, Code 128, EAN 128, Code 

39, Code 93 

 and Interleaved 2 of 5. 

 

Question: Can I use DW-PRT24T to print from the standard Windows applications 

(MS Word, Excel or Paint) and how? 

Answer: Yes. If you install a driver for a printer working with EPL2 language, you 

can print from any Win application. There are drivers for Windows 2000 and Windows 

XP in the installation diskette. For Windows 95 and Windows 98 you can download 

drivers at http://www.zebra.com. The Zebra LP2742 comes closest to the label size and 

settings for DW-PRT24T The DW-PRT24T Compatibility switch MUST be turned off. 

 

Question: Can I use DW-PRT24T to print text, not labels? 

Answer: Yes. However you can use only one font, and no print text parameters as 

bold, underlined etc. The commands for the printer are: 

 

· @2<LF>           Sets the printer in print text mode with font 2 (10x16). 



 

· @3<LF>           Sets the printer in print text mode with font 3 (12x20) 

 

· @4<LF>           Sets the printer in print text mode with font 4 (14x24) 

 

· @0<LF> Sets the printer in normal mode. 

 

Each command must be on a separate line ending in <LF> (ASCII code 10). Everything 

send between these two commands is printed as a text with the selected font. If the text is 

longer, it is automatically transferred to a new line. It is advisable when working in this 

mode to use continuous paper media. Switching off the printer will set the device in 

normal mode. 

 

Question:  What is the command language used by the printer and is it compatible 

with any standard? 

Answer:  The command language of DIGIWEIGH printers is based on EPL2 (Eltron 

Programming Language). Compatibility is not 100 % but is enough for the printers to 

work properly with most of the programs intended for these printers. The DIGIWEIGH 

printers have some new commands added mostly for the purpose of getting information 

from the printer, which is indispensable for DIGIWEIGH Label Editor. Another addition 

are the modifiers of the variables and the option to print linear text – both are not part of 

the EPL2 language. 

 

From the standard EPL2 commands some of the settings are not supported and choose the 

code tables for the languages in a different way. 

 

 

Creating a Label for Digital Scales - an Example 

 

As an example of creating a new label, we shall use L00, which is designed for work with 

digital scales DIGIWEIGH DWP-102N 

. The data from the weighed item will be printer on it.  

 

The choice of text and barcode font and size depends on the size of the label area. The 

name of the label must be one of the ten possibilities to program in the scales - L00, L01, 

… L09. Let us use L00. 

 

The weight data, which the scales will send, must be defined as variables. In this case, the 

printer offers more option and it must comply with the number of text lines sent by the 

scales. Their content is sent in the following order: 

 

· Company’s name – 28 symbols. 

 

· Item’s name - 28 symbols. 

 

· Weight in kg – 6 symbols (one of them being the decimal point). 



 

· Single item’s price in USD – 7 symbols. 

 

· Price – 7 symbols. 

 

· Barcode data – 12 symbols. 

 

· Scales logical number – 2 symbols. 

 

· Current date – 8 symbols. 

 

· Item’s number (PLU)-4 symbols. 

 

· Second line of item’s description – 28 symbols. 

 

· Third line of item’s description - 28 symbols. 

 

This is the ultimate total data number. The lines for the item’s description are an option to 

be selected from the scales. The label must match the selection; otherwise the printer will 

not print it. 

 

We shall have an example that does not use the additional lines for item’s description. 

We have then 9 variables. We must define 9 variables, no matter whether we shall need 

all of them. We must also keep in mind the symbol limit in the scales – if we define a 

variable with a shorter length, the printer will cut off the remaining symbols. If there will 

be not enough space for the full length of the fields, we must edit them in the scales – for 

example we can decrease the item’s name to 16 or 20 symbols. 

 

We start with the label. Let us work with a label with size 56x25 ìì and DW-PRT24T 

printer. The final result must be like this: 

 

The label contains 9 text fields, one barcode and one graphic. From Label Setup we 

choose: 

 

· Label size : 56/25 ìì 

· Width and Length will be automatically filled in. 

· Gap and Offset :  0. (Gap is not used when the paper media is label roll) 

· Date and Time format:  DD-MN-Y2 and H:M. The data string will be Day–

Month–Year (the month represented by digits, and the year - only by the last two digits). 

The time string will not contain the seconds. 

 

· Darkness: 8 and Speed : 50 mm/s. 

· Top and Left will have a 0 value, since label area is small. 

· Orientation: Top, Language : English 

· Paper: Normal Label. These are labels with NO black line. 

· Font: Condensed. We shall be able to place more date on the label. 



 

Now we must define the variables. From Define variables and counters we click the New 

button. We shall fill the fields with the values described bellow. This procedure must be 

repeated 8 more times – for each of the variables. 

 

Variable Prompt Length Justify Value 

Variable 0 Company 18 Left Supermarket ABC 

Variable 1 Item 24 Left Bananas 

Variable 2 Weight 6 None 1.20 

Variable 3 Single Price 6 Right 1.50 

Variable 4 Price 6 Right 1.80 

Variable 5 Barcode 1 None 240012401200 

Variable 6 Number 2 Left 01 

Variable 7 Date 8 Left 22.02.03 

Variable 8 PLU 4 Left 124 

 

We confirm the changes with OK. Note that we have defined some additional values – so 

as to view the elements of the label onscreen. 

 

The text alignment is selected according to the type of information and its position – the 

price and single price will be placed at the right part of the label and will aligned along its 

right end. 

 

We shall not use variable 7, since the printer has a clock, but we must define the variable, 

because it will receive the data from the scales. 

 

For some of the variables we set a length, shorter than the length sent by the scales. We 

did this to economize space – 

 otherwise the label will not contain all the information. 

 

Now we can start adding objects on to the label. We click the Draw Text button and left-

click on the opt-left corner of the label, where we want to place the first text – the 

company’s name. The draw text edit window is displayed. We can easily position the text 

object by dragging it with the mouse, so we shall not set the Start X and Start Y values in 

this window. The other options are: 

 

Size X (multiplication by X) 2 – the text will have a double-width. 

 

Size Y (multiplication by Y) 1 – original height 

 

Font 2 – size 10 x16 pixels. 

 

Style – Normal 

 

Rotation – None 

 



In the Text data field we must enter the data to be printed. What we enter is V0 – what 

shall be printed is the value of variable 0.  

 

After clicking OK, the text must appear on the label design. 

 

Then we repeat the procedure for the remaining text fields of the label: 

 

Size X Size Y Font Style Data Purpose 

1 1 3 Bold V1> < L16 Item’s name 

3 2 1 Normal V2"kg" Weight 

1 1 3 Bold V3"$/kg" Single price 

1 1 3 Bold V4"$" Price 

1 1 2 Normal "No: "V6 Scales number 

1 1 2 Normal "PLU:"V8 Item (PLU) 

1 1 3 Bold "Thank You!" Advertisement 

1 1 2 Normal TD" "TT Date and time 

 

You can see is a combination of variables and text. The first line of the table uses 

modifiers – the leading and end symbols of V1 are removed, and then only the first 16 

symbols are taken. The last but one line contains only text data, and the last line prints the 

current date and time from the clock of the printer. 

 

To add the barcode we select. We release the mouse at approximately the place of its top 

left corner. In the opened edit barcode window we make the following selection: 

 

Height – 64 

 

Narrow bar – 2 

 

Wide bar – 2. The value is not used for EAN13. 

 

HR text (display text) – Left. Text alignment for EAN13 is not available, unless you 

select None (no text is displayed). 

 

Rotation – None. 

 

Barcode – EAN13 . 

 

Barcode data - "24"V5R10 

 

The data contains a modifier – the first two digits of V5 are replaced by “24”, and the rest 

are preserved. If we want to print the original data from the scales, we must simply fill in 

V5. 

 

We shall add a picture element on to the label – in this case the logo of DIGIWEIGH. We 

press the Draw Picture button and release the mouse button at the desired position. In the 



opened window, we click on Load and select the file containing the logo. In the Store as 

filed we fill in DIGIWEIGH – this shall be the name of the graphic saved in the printer. 

After we click OK the picture will be displayed on the label design.  

 

At this stage, we have added all the elements of the label. We can additionally rearrange 

them by pressing the left mouse button. 

 

To save the label on the disk go to File->Save as Label. To save it the printer go to File-

>Store Current Label and enter a name L00. The printer is ready for work with the digital 

scales and the L00 label. Prior to connecting the printer, we must set one and the same 

speed (baud rate) for the serial ports and select label L00 in the scales 

 

 

Most Commonly Used Barcodes 

 

EAN 13 

 

EAN 8 

 

UPC-A 

 

UPC-E 

 

Code 128 

 

EAN 128 

 

Code 39 

 

Code 93 
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DIGIWEIGH DW-PRT24T 

 

The DW-PRT24T printer is designed to print small-sized labels and graphics on thermal 

paper rolls. The information is arranged in a template form, which can be partially 

modified under customer demand.  

 

The possibility to save the arrangement and design of the graphic elements as a form 

(command file) in the memory of the printer greatly enhances the production of a large 

quantity of labels. The support of PCX format allows you to create parts of the label with 

a Windows-based program and load them in the printer’s memory. Designing the text 

information on the label is facilitated by the 5 in-built matrix fonts with different sizes 

additional scalability and rotation. Additional fonts can also be loaded. The printer 



supports almost all most commonly used barcodes and this makes it a necessary 

component of your label production process. 

 

The result is a fast an flexible label printing method, resembling a laser printer work 

(resolution is 203 dpi). The printer can also print data from Windows applications (MS 

Word, Notepad etc.), with the necessary driver installed. 

 

Printer Management 

 

Printer management is done by means of commands sent through the serial interface. 

There are 8 supported baudrates, which are set by the position of several switches: 1200, 

2400, 4800, 9600, 19200, 38400, 57600 and 115200 bps, 8 bits, no control bit. The 

printer uses a hardware protocol, but supports a Xon/Xoff protocol as well. The 1200 bps 

speed is reserved for working with the local keyboard and label print without a computer 

or preliminary loading of forms. 

 

Configuration switches 

 

Sw1 Sw2 Sw3 Baudrate (bps) 

OFF OFF OFF 1200 (Local keyboard) 

ON OFF OFF 2400 

OFF ON OFF 4800 

ON ON OFF 9600 

OFF OFF ON 19200 

ON OFF ON 38400 

OFF ON ON 57600 

 

ON ON ON 115200 

 

OFF ON 

 

Sw4 Hardware protocol Xon/Xoff protocol 

 

Sw6 Paper roll mode Label roll mode 

Sw8 Normal mode DIGIWEIGH DW-PRT24T Compatibility 

 

Pressing the LF button in Paper roll mode feeds paper.  

 

Pressing the LF button in Label roll mode positions the printing mechanism at the 

beginning of the next label. 

 

If, when switching on the printer, you keep the LF button pressed down, the device will 

print out a diagnostic information and remain in diagnostics mode. When in this mode, 

the received data and printed data will be of hexadecimal type – it is not interpreted as 

commands. To go back to normal mode, switch off the printer. 

 



Indications 

 

POWER The indicator is green when the printer is switched on. 

ERROR The indicator blinks with a red light when there is a printing head 

overheat. 

PAPER The indicator lights in red when paper is out and blinks with a red light if 

there is no label. 

 

 


